不灭的焱

革命尚未成功,同志仍须努力

作者:php-note.com  发布于:2017-10-31 20:52  分类:HTML/CSS/JS  编辑

写博文时,一部小心点了浏览器的“关闭按钮”,没来得及保存,意味着先前写的内容白写了。。。

增加一段 js 代码,可以弹框提醒我们是否要真的关闭浏览器,用的是  Ckeditor 编辑器,参考代码如下:

<script>
    // 关闭页面确认弹出框
    window.onbeforeunload = function() {
        if (ck_obj_content.getData()) {
            return ('确认要关闭页面吗?');
        }
    };
</script>
作者:php-note.com  发布于:2017-10-31 09:54  分类:PHP库/系统/微信  编辑

Swoole 用到的系统调用

(1) 内存管理

     FixedPool 固定分配内存池

     RingBuffer 环形内存缓冲区

(2) 定时器:timefd

(3) 信号处理:signalfd

(4) 数据通信:eventfd  + mmap

作者:php-note.com  发布于:2017-10-29 22:37  分类:Windows服务器  编辑

在Server2012打开 服务器管理器,选择 添加角色与功能,添加Web服务下的FTP服务器

作者:php-note.com  发布于:2017-10-29 21:09  分类:MySQL/NoSQL  编辑
作者:php-note.com  发布于:2017-10-26 22:33  分类:PHP库/系统/微信  编辑

解决方法:

在php程序代码里面设置报警级别

<?php
error_reporting(E_ALL ^ E_DEPRECATED);

Deprecated 的问题就这样解决掉了,不过还是建议大家尽快取消 mysql 的用户,全部都走向 mysqli 或者 mysqlnd 等等。mysql 确实是太不安全而且太老旧了。

作者:php-note.com  发布于:2017-10-23 14:15  分类:Go/Python  编辑

Golang 定位解决分布式系统,服务器应用开发,主要竞争对手是 Java、Python 之类;Rust 定位解决单机安全问题,高性能场景偏系统底层开发,主要竞争对手就是 C 和 C++。

作者:php-note.com  发布于:2017-10-18 17:17  分类:Go/Python  编辑
作者:php-note.com  发布于:2017-10-18 17:14  分类:Linux_C  编辑

我用的是 cmake 编译,增加参数 -fgnu89-inline ,参考代码如下:

add_definitions(-fgnu89-inline)

参考:cmake参数 与 命令详解

 

作者:php-note.com  发布于:2017-10-18 16:20  分类:Java  编辑
作者:php-note.com  发布于:2017-10-08 21:32  分类:PHP库/系统/微信  编辑
作者:php-note.com  发布于:2017-10-08 21:29  分类:Linux软件安装/优化  编辑
作者:php-note.com  发布于:2017-10-08 21:28  分类:Linux软件安装/优化  编辑

到 adobe 官方下载 flash插件 flash_player_ppapi_linux

~/.config/google-chrome/PepperFlash下建个目录 23.0.0.185,把 libpepflashplayer.somanifest.json 拷入

修改 /usr/share/applications/google-chrome.desktop

Exec=/usr/bin/google-chrome-stable %U 

改为 Exec=/usr/bin/google-chrome-stable %U --ppapi-flash-path=/home/用户名/.config/google-chrome/PepperFlash/23.0.0.185/libpepflashplayer.so --ppapi-flash-version=23.0.0.185

重启一下 chrome 就可以了!

作者:php-note.com  发布于:2017-10-08 21:28  分类:Linux软件安装/优化  编辑

参考先前的文章(Ubuntu 14 安装并破解SSH工具 SecureCRT),破解安装 SecureCRT-7.3  成功,但是破解安装 SecureFX-7.3 时就一直报错:

Insufficient privileges, please switch the root account. at securecrt_linux_crack.pl line 88.

作者:php-note.com  发布于:2017-10-08 21:27  分类:Linux软件安装/优化  编辑

硬盘是 500G,先前安装 Windows7 时,分了3个区,大小分别为 90G、100G、310G,现在用 Deepin 重装系统时,挂载情况如下:

/dev/sda1 分区作为 /(挂载点),类型为 ext4

/dev/sda2 分区作为 /home(挂载点),类型为 ext4

/dev/sda3 分区无挂载点,类型为 ext4

因为 /dev/sda3 还没有被挂载,也就用不了,,,挂载操作如下:

作者:php-note.com  发布于:2017-10-07 21:26  分类:Linux软件安装/优化  编辑

1、罗技的“无线优联技术”还是非常强大的,它跟具体的操作系统无关;

2、你只需要 让“优联接收器(一个USB设备)”跟 “无线键盘/鼠标” 配对即可,配对完之后,就无需再配对,即使把“优联接收器”插到其他电脑,无线设备(键盘/鼠标)也照用可用;

3、官方提供了一个让“优联接收器”跟 “无线设备”配对的中间软件(点击下载),但可惜的是,只有 Windows 版本!

所以,我们随便找一台 Windows 机,装上上述的配对中间软件,然后参考教程(如何安装 罗技“优联技术”无线鼠标、无线键盘?),完成配对即可;

作者:php-note.com  发布于:2017-10-07 21:25  分类:Linux软件安装/优化  编辑

软件环境

宿主机系统:Deepin 15.4.1,

虚拟机软件:VirtualBox 5.1

虚拟机系统:XP

作者:php-note.com  发布于:2017-10-06 21:24  分类:Linux软件安装/优化  编辑

自带的 软件包源 不好用,卡顿严重,准备替换它:

方式一:deepin linux 如何更新或者更换软件源(注意:好像不起作用)

方式二:【推荐利用 阿里云 提供的镜像快速更换本地的 yum 源 (CentOS/Ubuntu/Deepin 等系统都被支持),找到“deepin”,点击右边的“帮助”,会告诉你如何替换为“阿里云源”

作者:php-note.com  发布于:2017-10-04 21:24  分类:Linux软件安装/优化  编辑

使用 Deepin 过程中,发现当点击“任务栏”上面的按钮,尤其是右键单击,选择菜单时,界面很容易卡顿,再也动弹不了。

好吧,,,就不使用自带的“任务栏”了,换成一个轻量级的“任务栏tint2”,

作者:php-note.com  发布于:2017-10-03 21:23  分类:Linux软件安装/优化  编辑

编译 Nginx

#安装依赖库
sudo apt-get -y install libpcre3 libpcre3-dev
sudo apt-get -y install libssl-dev openssl libcurl4-openssl-dev
sudo apt-get -y install build-essential libtool
 
#安装pcre库
cd /alidata/tmp/deepin-sdk/source2/nginx
sudo tar -xzvf ./pcre-8.36.tar.gz
cd ./pcre-8.36
sudo ./configure
sudo make && sudo make install
作者:php-note.com  发布于:2017-10-02 21:22  分类:Linux软件安装/优化  编辑

1、开启 ls 别名: sudo vim /etc/profile

追加以下代码

alias ll='ls -l' alias la='ls -A' alias l='ls -CF'