不灭的焱

革命尚未成功,同志仍须努力

作者:php-note.com  发布于:2017-10-26 22:33  分类:PHP库/系统/微信  编辑

php 5个版本 5.2、5.3、5.4、5.5,怕跟不上时代,新的服务器直接上 5.6,但是程序出现如下错误:

Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in

看意思就很明了,说 mysql_connect 这个模块将在未来弃用,请你使用 mysqli 或者 PDO 来替代。

解决方法1:

禁止php报错

display_errors = On

改为

display_errors = Off

鉴于这个服务器都是给用户用的,有时候他们需要报错(…都是给朋友用的,^_^),不能这做,让他们改程序吧,看方案2.

解决方法2:

常用的 php 语法连接 mysql 如下

<?php
$link = mysql_connect('localhost', 'user', 'password');
mysql_select_db('dbname', $link); 

改成 mysqi

<?php
$link = mysqli_connect('localhost', 'user', 'password', 'dbname');

常用mysql建表SQL如下

<?php
//  老的
mysql_query('CREATE TEMPORARY TABLE `table`', $link);

// 新的
mysqli_query($link, 'CREATE TEMPORARY TABLE `table`');

解决方法三:

在php程序代码里面设置报警级别

<?php
error_reporting(E_ALL ^ E_DEPRECATED);

Deprecated 的问题就这样解决掉了,不过还是建议大家尽快取消 mysql 的用户,全部都走向 mysqli 或者 mysqlnd 等等。mysql 确实是太不安全而且太老旧了。