不灭的焱

革命尚未成功,同志仍须努力

作者:php-note.com  发布于:2021-04-04 18:09  分类:Java框架/系统  编辑

简介

在创建Maven工程的时候,mysql-connector-java与MySQL数据库的版本如果不对应,运行的时候将会报错,于是整理一下他们之间的版本对应关系

对应关系

mysql-connector-java MySQL JDBC JDK 说明
8.0.x 5.6、5.7、8.0 4.2 JDK 8.0或更高版本 全面上市,推荐版本。
5.1.x 5.6、5.7、8.0 3.0、4.0、4.1、4.2 JDK 5.0和JDK 8.0或更高版本 一般可用性

Maven地址

https://mvnrepository.com/artifact/mysql/mysql-connector-java

依赖:(8.0.23)

<dependency>
    <groupId>mysql</groupId>
    <artifactId>mysql-connector-java</artifactId>
    <version>8.0.23</version>
</dependency>

官网文档地址

https://dev.mysql.com/doc/connector-j/5.1/en/connector-j-versions.html (Connector/J Versions 5.1)

https://dev.mysql.com/doc/connector-j/6.0/en/connector-j-versions.html (Connector/J Versions 6.0)

https://dev.mysql.com/doc/connector-j/8.0/en/connector-j-versions.html (Connector/J Versions 8.0)