不灭的焱

革命尚未成功,同志仍须努力下载JDK17

作者:Albert.Wen  添加时间:2024-06-30 15:36:46  修改时间:2024-07-21 13:18:11  分类:01.C#/DevExpress  编辑

本文整理记录了 DevExpress 各个版本与 .NET 和 Visual Studio 和各版本之间的兼容性,以备有需要的开发人员速查。

相关文章:

DevExpress 版本号说明

DevExpress 的版本号结构如下:[year].[major].[minor].[hotfix]

  • year(年份):,即发布年份的后两位,如 2023 年发布的版本此处为 23。

  • major(主要版本):每年上、下半年分别发布一个主要版本,此处分别为 1 和 2,如 2023 年下半年发布的主要版本为 23.2。

    • 不同主要版本的开发环境可以并行安装,如 23.2 和 19.1 可以同时安装在一台计算机上。

    • 同一个主要版本内部的多个版本无法并行安装,如安装 23.1.7 会对 20.1.3 执行就地更新。

  • minor(次要版本):每个主要版本发布后,会每隔一到三个月发布一个新的次要版本,进行错误修复和少量的功能、性能增强,有可能引入少量的破坏性变更。

  • hotfix(热修复版本):每个次要版本首次发布时无该段版本号。次要版本发布周期内可能会发布仅进行少量错误修复的热修复版本。

各版本详细信息可参见 DevExpress 版本信息页

DevExpress 的版本兼容性

不同版本的 DevExpress 组件对 .NET 和 Visual Studio 的不同版本有着不同的支持情况。

详细的支持矩阵可参见 DevExpress WinForms 组件需求页

DevExpress 支持的 .NET, Visual Studio 版本

各版本 DevExpress 对各版本 .NET 实现以及 Visual Studio 的支持范围如下:

DevExpress 版本 支持的 .NET 版本 支持的 VS 版本
v23.2 .NET Framework 4.5.2 - 4.8, .NET 6, .NET 7, .NET 8 2015 - 2022
v22.2, v23.1 .NET Framework 4.5.2 - 4.8, .NET 6, .NET 7 2015 - 2022
v21.2, v22.1 .NET Framework 4.5.2 - 4.8, .NET Core 3.0/3.1, .NET 5, .NET 6 2012 - 2022
v20.1 - v21.1 .NET Framework 4.5.2 - 4.8, .NET Core 3.0/3.1, .NET 5 2012 - 2019
v19.2.5+ .NET Framework 4.5.2 - 4.8, .NET Core 3.0/3.1 2012 - 2019
v19.1 - v19.2.4 .NET Framework 4.5.2 - 4.8, .NET Core 3.0 2012 - 2019
v18.2.7+ .NET Framework 4.5.2 - 4.8 2012 - 2019
v18.1.11 - v18.2.6 .NET Framework 4.0 - 4.7 2010 - 2019
v16.2 - v18.1.10 .NET Framework 4.0 - 4.7 2010 - 2017
v16.1.11+ .NET Framework 4.0 - 4.6 2010 - 2017
v14.2 - v16.1.10 .NET Framework 4.0 - 4.6 2010 - 2015

.NET 支持的 DevExpress 版本

.NET 各版本所支持 DevExpress 的版本范围如下:

.NET 版本 DX 最低版本 DX 最高版本
.NET 8 (LTS) v23.2 -
.NET 7 (STS) v22.2 -
.NET 6 (LTS) v21.2 -
.NET 5 (EOL) v20.1 v22.1
.NET Core 3.1 (EOL) v19.2.5 v22.1
.NET Core 3.0 (EOL) v19.1 v22.1
.NET Framework 4.8 v18.2 -
.NET Framework 4.7 v16.2 -
.NET Framework 4.6.2 v14.2 -
.NET Framework 4.6 (EOL) v14.2 -
.NET Framework 4.5.2 (EOL) v12.1 -
.NET Framework 4.5 (EOL) v12.1 v18.1
.NET Framework 4.0 (EOL) v10.1 v18.1
.NET Framework 3.5 - v12.2
  • STS: Standard Term Support, 标准期限支持(18 个月)
  • LTS:Long Term Support, 长期支持(3 年)
  • EOL:End of Life, 生命周期已结束

Visual Studio 支持的 DevExpress 版本

Visual Studio 各版本所支持 DevExpress 的版本范围如下:

Visual Studio 版本 DX 最低版本 DX 最高版本
Visual Studio 2022 v21.2 -
Visual Studio 2019 v18.1.11, v18.2.7 -
Visual Studio 2017 v16.1.11 -
Visual Studio 2015 v14.2 -
Visual Studio 2013 v12.2.15 v21.1
Visual Studio 2012 (EOL) v12.1 v21.1
Visual Studio 2010 (EOL) v10.1 v18.1

其他说明

  • v22.1 是支持 .NET Core 3.x, .NET 5 以及 Visual Studio 2012, 2013 的最高版本。
  • v18.1 是支持 .NET Framework 4.0 - 4.5.1 的最高版本。
  • v12.2 是支持 .NET Framework 3.5 的最高版本。
  • v12.1 - v12.2.14 支持 Visual Studio 2008 - 2012,v12.2.15-v14.1 支持 Visual Studio 2010 - 2013。

更新日志

  • 2024 年 1 月 4 日更新:DevExpress v23.2 发布。
  • 2023 年 6 月 14 日更新:DevExpress v23.1 发布。
  • 2022 年 12 月 10 日更新:DevExpress v22.2 发布。
  • 2022 年 6 月 21 日更新:DevExpress v22.1 发布。
  • 2021 年 11 月 4 日更新:DevExpress v21.2 发布。
  • 2021 年 5 月 27 日更新:DevExpress v21.1 发布。
  • 2020 年 10 月 28 日更新:DevExpress v20.2 发布。

 

 

摘自:https://www.cnblogs.com/vxchin/p/compatibilities-of-devexpress-versions.html