不灭的焱

革命尚未成功,同志仍须努力下载JDK17

作者:Albert.Wen  添加时间:2023-10-23 19:59:17  修改时间:2024-02-22 16:49:53  分类:前端/Vue/Node.js  编辑

这是原来chunchun的方式来检验文件的后缀是否为excel格式(需要自己写js来判断),效果就是这种chouchou的原来的效果:

作者:Albert.Wen  添加时间:2023-10-20 00:11:41  修改时间:2024-02-24 14:59:10  分类:前端/Vue/Node.js  编辑

vxe-table组件,本身自带一个height属性,height属性可以设置按百分比%设置,也可以按px设置,另外可以设置为'auto'。官方文档对于设置为'auto'的解释如下:

支持铺满父容器或者固定高度,如果设置 auto 为铺满父容器(如果设置为 auto,则必须确保存在父节点且不允许存在相邻元素)

作者:Albert.Wen  添加时间:2023-10-19 23:17:08  修改时间:2024-02-23 08:27:17  分类:前端/Vue/Node.js  编辑

开发中表格功能是很常见的功能,自适应高度也是比较头疼的问题。

作者:Albert.Wen  添加时间:2023-10-15 17:36:52  修改时间:2024-02-24 21:15:14  分类:前端/Vue/Node.js  编辑

vxe-table:一个基于 vue 的 PC 端表格组件,支持增删改查、虚拟滚动、懒加载、快捷菜单、数据校验、树形结构、打印导出、表单渲染、数据分页、虚拟列表、模态窗口、自定义模板、渲染器、贼灵活的配置项、扩展接口等…

作者:Albert.Wen  添加时间:2023-10-15 13:25:45  修改时间:2024-02-22 19:43:36  分类:前端/Vue/Node.js  编辑

在项目开发过程中,不同项目使用的nodejs版本不同,有时会因为node版本过高或太低,导致报错

作者:Albert.Wen  添加时间:2023-10-13 10:32:58  修改时间:2024-02-23 13:56:08  分类:前端/Vue/Node.js  编辑

行/列合并:设置属性 span-method 可以指定合并行或列的算法。

作者:Albert.Wen  添加时间:2023-10-11 19:18:43  修改时间:2024-02-25 02:27:22  分类:前端/Vue/Node.js  编辑

其原因是因为固定的列的高度过高,覆盖了滚动条,导致点击到的元素并不是滚动条

这个是我们只需要修改一下 固定列的高度让他把滚动条漏出来就行

作者:Albert.Wen  添加时间:2023-10-07 16:36:02  修改时间:2024-02-21 18:21:04  分类:前端/Vue/Node.js  编辑

在项目开发过程中,不同项目使用的nodejs版本不同,有时会因为node版本过高或太低,导致报错;

作者:Albert.Wen  添加时间:2023-10-07 15:57:28  修改时间:2024-02-24 18:57:29  分类:前端/Vue/Node.js  编辑

拉取后点击左侧“合并更改”里的文件,会出现以下界面。根据实际情况修改冲突代码,修改保存后提交到本地仓库。

作者:Albert.Wen  添加时间:2023-10-07 00:15:18  修改时间:2024-02-20 10:15:44  分类:前端/Vue/Node.js  编辑

在实际项目开发中,几乎每个组件中都会用到 axios 发起数据请求。此时会遇到如下两个问题:

① 每个组件中都需要导入 axios(代码臃肿)

② 每次发请求都需要填写完整的请求路径(不利于后期的维护)