PHP笔记网

革命尚未成功,同志仍须努力下载JDK17

作者:Albert.Wen  添加时间:2022-03-05 20:55:43  修改时间:2024-05-23 04:22:49  分类:Linux软件安装/参数优化  编辑

OpenJDK17 下载地址:https://jdk.java.net/  (jdk17

作者:Albert.Wen  添加时间:2022-02-27 23:31:01  修改时间:2024-05-22 09:03:11  分类:Linux软件安装/参数优化  编辑

不用管上述的configure错误,直接执行下一步的make命令即可:

make ZEND_EXTRA_LIBS='-liconv'
make install
作者:Albert.Wen  添加时间:2022-02-27 22:37:04  修改时间:2024-05-21 22:54:50  分类:Linux软件安装/参数优化  编辑

CentOS 7编译安装 PHP 7.4时,报错:

configure: error: Package requirements (oniguruma) were not met:

No package 'oniguruma' found

作者:Albert.Wen  添加时间:2022-02-27 20:45:18  修改时间:2024-05-15 00:52:00  分类:Linux软件安装/参数优化  编辑
作者:Albert.Wen  添加时间:2022-02-06 15:45:32  修改时间:2024-05-14 13:53:26  分类:Linux软件安装/参数优化  编辑

今天看到服务器提示有漏洞需要更新,在执行更新命令的时候一直报错,因为CentOS 6操作系统版本结束了生命周期(EOL),Linux社区已不再维护该操作系统版本,导致不能正常更新。

作者:Albert.Wen  添加时间:2021-10-11 02:09:45  修改时间:2024-05-18 22:52:21  分类:Linux软件安装/参数优化  编辑

CentOS7的Python包管理(1) 卸载Python3

CentOS7的Python包管理(2) pip的删除及安装(配置国内Python包镜像)

CentOS7的Python包管理(3) 安装Python2和Python3

CentOS7的Python包管理(4) 安装pyenv(Python多版本管理)

CentOS7的Python包管理(5) 安装virtualenv、virtualenvwrapper(Python虚拟环境管理)

通过以上文章的学习,终于知道如何管理Python多版本和依赖包的隔离问题,下面记录一下自己在CentOS7环境下管理Python环境的笔记

作者:Albert.Wen  添加时间:2021-10-10 01:10:44  修改时间:2024-05-03 02:57:26  分类:Linux软件安装/参数优化  编辑

动态语言Ruby、Python都有自己的虚拟环境,虚拟环境是程序执行时的独立执行环境,在同一台服务器中可以创建不同的虚拟环境供不同的系统使用,项目之间的运行环境保持独立性而相互不受影响。例如项目可以在基于Python2的环境中运行,而项目B可以在基于Python3的环境中运行。Python通virtualenv工具管理虚拟环境。

作者:Albert.Wen  添加时间:2021-10-09 12:08:51  修改时间:2024-05-15 02:49:25  分类:Linux软件安装/参数优化  编辑

一般在操作系统中我们会安装多个Python版本,在*nix系统中一般默认就自带了Python2与Python3两个版本,所以在进行Python版本切换时会比较麻烦,pyenv就提供了一种简单的方式。

pyenv是一个能简易地在多个Python版本中进行切换的工具,它简单而优雅。

作者:Albert.Wen  添加时间:2021-09-27 11:43:26  修改时间:2024-05-03 11:03:13  分类:Linux软件安装/参数优化  编辑

CentOS7默认安装的是Python 2.7.5,但不知道是哪个时候,安装了Python3.6,后面在包管理方面,搞的有冲突,比较混乱,有的项目需要Python3环境、有些需要Python2环境,干脆先把非系统自带的Python3卸载掉吧!

作者:Albert.Wen  添加时间:2021-09-27 00:30:00  修改时间:2024-05-23 05:20:39  分类:Linux软件安装/参数优化  编辑

软件包管理极其重要,所以自 Python3 的 3.4 版本以及 Python2 的 2.7.9 版本开始,pip 一直被直接包括在 Python 的安装包内,同样还被用于 Python 的其它项目中,这使得 pip 成为了每一个 Pythonista(Python用户)必备的工具。